Cannot enable Active mode

If you got some trouble or need help configuring AirDC++, we're here to help

Cannot enable Active mode

Postby stan » 03 May 2020, 00:07

whatismyip.com displays both my public ipv4 and ipv6 addresses.

With only ipv4 enabled the log shows:

Connectivity (IPv4): Determining the best connectivity settings...
Connectivity (IPv4): Local network with possible NAT detected, trying to map the ports...
Connectivity (IPv4): Port mapping: Successfully created port mappings (Transfers: 12345, Encrypted transfers: 23456, Search: 34567) on the "XYZ" device with the MiniUPnP interface

!myinfo on a hub shows "Mode: A", but search doesn't work and downloading filelists always times out, so it looks like I'm in Passive mode after all.

With only ipv6 enabled the log shows:

Connectivity (IPv6): Determining the best connectivity settings...
Connectivity (IPv6): Public IP address detected, selecting active mode with direct connection

However now !myinfo on the same hub shows "Mode: P" and of course I'm still in Passive mode.

So my question is - why can't I seem to actually enable Active mode no matter what, despite the client even stating that I am in Active mode when only ipv6 is active?
stan
 
Posts: 4
Joined: 02 May 2020, 23:49

Re: Cannot enable Active mode

Postby maksis » 03 May 2020, 08:50

Generally you can use IPv6 only if you connect the hub via an IPv6 address as current hubsofts don't support hybrid connectivity. Otherwise it's forced to use IPv4 even if it's disabled. Regarding the issues with active mode, I recommend reading https://dcplusplus.sourceforge.io/webhe ... ction.html
User avatar
maksis
Site Admin
 
Posts: 896
Joined: 23 Nov 2010, 18:56

Re: Cannot enable Active mode

Postby stan » 03 May 2020, 16:33

Thanks, but I've gone through all those pages already and tried everything therein to no avail.

The private hubs I'm on don't mention any ipv6 addresses. I'll ask, but probably they're ipv4 only.

So, anything else I can try, or am I doomed forever to the horrors of Passive mode (which restricts me severely from the hubs I am allowed on as well)?
stan
 
Posts: 4
Joined: 02 May 2020, 23:49

Re: Cannot enable Active mode

Postby maksis » 03 May 2020, 16:41

Have you tried manual port forwarding and a port checker (such as https://www.yougetsignal.com/tools/open-ports/)? Try disabling Windows firewall and possible other software firewalls. IPv6 probably wouldn't help you with getting more sources even if you managed to connect via IPv6 since most users only support IPv4.
User avatar
maksis
Site Admin
 
Posts: 896
Joined: 23 Nov 2010, 18:56

Re: Cannot enable Active mode

Postby stan » 03 May 2020, 16:55

Yes, I've tried Windows UPnP, MiniUPnP/NAT-PMP, manual forwarding etc., but all ports still show up as closed. :(

Also, for some reason my External/WAN IP (as shown in the program) keeps changing to 100.122.x.y from my real one. Could that be part of the problem or indicate what's going on?
Last edited by stan on 03 May 2020, 19:31, edited 1 time in total.
stan
 
Posts: 4
Joined: 02 May 2020, 23:49

Re: Cannot enable Active mode

Postby maksis » 03 May 2020, 17:12

stan wrote:Also, for some reason my External/WAN IP keeps changing to 100.122.x.y from my real one. Could that be part of the problem or indicate what's going on?


That IP belongs to a shared address space: https://en.wikipedia.org/wiki/IPv4_shared_address_space

If your ISP implements NAT for all customers, I doubt that you'll be able to use active mode via IPv4.
User avatar
maksis
Site Admin
 
Posts: 896
Joined: 23 Nov 2010, 18:56

Re: Cannot enable Active mode

Postby stan » 03 May 2020, 19:31

So basically what it boils down to is, unless the hub software uses ipv6 I cannot be Active, and even if it does I won't be able to connect to most users who're still using ipv4?
stan
 
Posts: 4
Joined: 02 May 2020, 23:49

Re: Cannot enable Active mode

Postby maksis » 03 May 2020, 20:39

stan wrote:So basically what it boils down to is, unless the hub software uses ipv6 I cannot be Active, and even if it does I won't be able to connect to most users who're still using ipv4?


Yeah
User avatar
maksis
Site Admin
 
Posts: 896
Joined: 23 Nov 2010, 18:56


Return to The Help Desk

Who is online

Users browsing this forum: No registered users and 12 guests

cron