Page 1 of 1

[SOLVED] Crash immediately upon starting

PostPosted: 06 Dec 2018, 15:56
by Lonewolf79
Using the latest version 3.52 for Windows 10 I get "Assertion failed" as soon as I start the program.
I even tried ApexDC++ just to see if it would work, and while the program started as soon as I tried to view a file list or something similar it crashed with the same error.
Leading me to believe it has something to do with my computer. Windows 10 x64 and it is very recently installed

debug text here:

https://pastebin.com/a8S55AQx

Re: Crash immediately upon starting

PostPosted: 06 Dec 2018, 17:03
by maksis
It's a strange crash indeed. Could it be memory-related? Do you have any antivirus software installed (or any other similar software)?

Re: Crash immediately upon starting

PostPosted: 15 Dec 2018, 13:02
by Lonewolf
This is me who started this topic. My account got lost on me somehow.

Anywho, I have no anti-virus running apart from the "built-in" windows defender.
I've re-installed Windows 10 two times, full whipe and install. Getting the exact same error :/

No idea about memory. So far this program is the only one that is behaving badly.
Any idea? Tried to install and de-install all various versions of Visual c++ from microsoft

// Lonewolf

Re: Crash immediately upon starting

PostPosted: 29 Dec 2018, 23:16
by curse
A friend of me got exactly the same problem, and looking at the debug , it refers to file
"c:\projects\airdc-git\boost\libs\regex\src\w32_regex_traits.cpp" line 123
Is it perhaps an error in boost which shows itself for some users? My friend also tried Apex and got the same error when downloading the file list from a few but not all users.
We're investigating, and I'll write here if we find something out.
Since the problem also seems to be in Apex, it might be something from upstream, perhaps in Boost, perhaps in DC++.

Re: Crash immediately upon starting

PostPosted: 30 Dec 2018, 14:50
by maksis
https://github.com/airdcpp/airgit/blob/ ... s.cpp#L123

Possibly AirDC++ should define BOOST_NO_ANSI_APIS that would use a different code path... (I'm not able to provide a build with that macro enabled in a while but maybe someone else could test it)

Re: Crash immediately upon starting

PostPosted: 01 Jan 2019, 19:29
by curse
I guess it's not possible to build in Linux? I can try to setup the Win7 I have in VirtualBox for it.
I'll check if you got any info on what's needed for building it.

Re: Crash immediately upon starting

PostPosted: 01 Jan 2019, 20:20
by Nimbus2500TDI
Hello, I have that same problem right after a mayor format!
This one:

Right after the format and activating Windows, I updated Windows and updated the drivers thru my MoBo Driver App! Then I, after Total Commander, CPU-Z,Aida64 and GeForce Experience + Update Video Drivers.. installed DC++ 0,868! And I have added some share..

Then I installed a second client AirDc++ .. for another use.. And it gave this error on startup !

I thought these two clients don't work together or share the same options or something like that!?
So I uninstalled DC++ 0.868, and installed ApexDC++ Becouse I knew for sure from earlier that these two can co-exist!? ApexDC++ and AirDC++ …

And Apex started up normaly .. but first user I chcked for filelist gave the same error!
The rest of users was no problem to get file list from!

My fealing was that DC++ 0.868 and AirDC++ couldn't co-exist and that the registry was f*ed up!?
So I wanted to format and reinstall the entire deal again from scratch ..

Then I read Lonewolf stating that even formatting didn't help, and that the issue affects not onley me ..


So.. Is there a solution to this issue yet, and did Lonewolf fix it already ?

Re: Crash immediately upon starting

PostPosted: 06 Mar 2019, 00:40
by Sopor
To fix this you need to install "2019-02 Cumulative update KB4482887". Run Windows Update!

Re: Crash immediately upon starting

PostPosted: 11 Mar 2019, 12:10
by Nimbus2500TDI
Sopor wrote:To fix this you need to install "2019-02 Cumulative update KB4482887". Run Windows Update!



Yes sir... this fixed the Assertio Fail Error here!

But why me?