Page 1 of 1

Problem With Symbolic Links

PostPosted: 25 Mar 2020, 12:16
by FLASK59
Hi ,

it's been 2 days, and I still can't solve the problem :(

first of all :

Lines Green
= present in my sharing or download
Lines Red = not present in my sharing

in my share I have complete folder and folder (symbolic link = 0 bytes)

--------------------------------------------
when i click on BROWSE file list of user , the result : symbolic link included in the list = lines Green
when i click on GET file list of user , the result : symbolic link no included in the list = lines Red

I do not understand , very help me !!!!!!!!

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 18:21
by maksis
What are those colored lines and where do the colors come from? Were there meant to be images in your post?

What is your application version?

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:03
by FLASK59
tested with version : 3.60 and 3.61a-62-g8d8fe x64

1.colors come from there :

to see the whole image, right click to display the image
Image

2.release in my share (file , browse own list)

to see the whole image, right click to display the image
Image

3.search release and green result = present in my share

to see the whole image, right click to display the image
Image

4.right click browse file list and green result = present in my share

to see the whole image, right click to display the image
Image

5.click get full list and red result = no present :( ( problem )

to see the whole image, right click to display the image
Image

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:14
by maksis
When you use "Browse filelist", it will match the directories by name with your own share. It's the same for directory search results.

When using "Get filelist", it won't match directory names (only the files inside the directory are being matched). If there are no files inside the directory (or you aren't sharing the same files), it won't be detected as dupe in your share.

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:17
by FLASK59
How can I do ? :cry: :cry:

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:19
by maksis
You need to use "Browse filelist" if you want to match the directory names with own share. It's not supported with full filelists.

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:21
by FLASK59
with ADLSearch it's the same as get list ?

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:24
by FLASK59
maksis wrote:You need to use "Browse filelist" if you want to match the directory names with own share. It's not supported with full filelists.


possible in a future update ?

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:25
by maksis
FLASK59 wrote:with ADLSearch it's the same as get list ?


Not really. ADL search won't perform recursive matching in partial filelists. Only for the directories that have been loaded (=viewed).

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:27
by maksis
FLASK59 wrote:possible in a future update ?


You could post a separate feature request explaining your use case (and what are the symbolic links that you need to match). I won't promise anything though as "Get filelist" is somewhat a legacy feature, which I'm not actively working on.

Re: Problem With Symbolic Links

PostPosted: 25 Mar 2020, 19:42
by FLASK59
thanks for the answers , who should i contact ?